Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
TEM1KK
22.11.2020 04:46 •
Информатика
Написать программу поиска суммы положительных чисел, вводимых с клавиатуры. как только будет введено отрицательное число, суммирование прекратить.
Показать ответ
Ответ:
ніка65
07.10.2020 21:01
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
write(ReadSeqIntegerWhile(x->x>=0).Sum());
end.
0,0
(0 оценок)
Ответ:
AsyaUkrainceva
07.10.2020 21:01
Var
A,S: real;
Begin
S := 0;
Write('Введите последовательность чисел: ');
Read(A);
While A >= 0 do
Begin
S := S + A;
Read(A);
End;
WriteLn('S = ',S);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
kazashkatv
18.11.2020 02:32
Вправа 1. завдання «переїзд до києва» улітку ви з родиною збираєтеся переїхати жити до києва, оскільки батьки там працюють. ви вже обрали вищий навчальний заклад...
kolasalnov5
08.02.2023 15:13
Задан двумерный массив в из 6-и строк и 3-х столбцов. составить программу, которая организует одномерный массив с, элементы которого равны количеству положительных...
Marshall123
04.07.2022 11:03
1. какие два объекта образуют видеосистему персонального компьютера? 2. в зависимости от создания графического изображения различают два вида графики. какие?...
Апостол16
20.10.2021 20:28
Написать программу на языке паскаль пользователь вводит x, y и z. программа находит:...
077771086
08.05.2023 18:58
Доклад на тему редактирование текста...
KiloMETR1336
17.08.2021 15:32
Преобразовать алгоритм, записанный на алгоритмическом языке в программу на языке pascal. алг выражение нач цел х вещ у ввод х если х 0 то у: =sqrt иначе y: =аbs...
vyachik2000
08.02.2021 23:27
На с++! ! вводится определенное кол-во строк, требуется вывести строки в порядке уменьшения(от строки в которой больше всего символов , до той в которой меньше...
vika10092005
26.11.2022 08:28
Для каждой создайте алгоритм и программу. заполните одномерный числовой массив b(15) случайными целыми числами в интервале [-6; 12]. выведите значение элементов...
Zhenkyaaaa
31.12.2020 17:31
Контрольная работа по информатике 7 класс итогавая решите ...
sgsfgff
13.10.2021 11:25
Четыре примера расширений графических файлов....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Версия 3.3, сборка 1611
begin
write(ReadSeqIntegerWhile(x->x>=0).Sum());
end.
A,S: real;
Begin
S := 0;
Write('Введите последовательность чисел: ');
Read(A);
While A >= 0 do
Begin
S := S + A;
Read(A);
End;
WriteLn('S = ',S);
End.