Для каждой создайте алгоритм и программу. заполните одномерный числовой массив b(15) случайными целыми числами в интервале [-6; 12]. выведите значение элементов массива сначала в столбик, а затем в строку, причем на каждый элемент отведите 4 позиции. ответ каждой следует выводить с новой строки и с пояснительным текстом. кроме того следует каждый раз производить вывод массива на экран если в нем произошли изменения: перестановка изменения значения элементов и т.д. 1) найдите сумму элементов с нечетными номерами 2)найдите произведение положительных элементов 3)найдите минимальный по значению элемент массива 4)замените все элементы которые больше 3 на значение минимального элемента массива 5)осуществите постановку 5-го и и минимального элементов массива
using namespace std;
int main() {
int n;
cout << "Ââåäèòå êîëè÷åñòîâ äîìîâ: ";
cin >> n;
cout << endl;
cout << "Ââåäèòå êîëè÷åñòâî æèòåëåé â êàæäîì äîìå: ";
int chet = 0, nechet = 0;
for (int i = 0; i < n; i++)
{
int x;
cin >> x;
if (i % 2 == 0)
chet += x;
else
nechet += x;
}
cout << endl;
if (chet == nechet)
cout << "Ðàâíîå êîëè÷åñòâî æèòåëåé íà îáåèõ ñòîðîíàõ óëèöû." << endl;
else
if (chet > nechet)
cout << "Áîëüøå æèòåëåé íà ÷åòíîé ñòîðîíå óëèöû." << endl;
else
cout << "Áîëüøå æèòåëåé íà íå÷åòíîé ñòîðîíå óëèöû." << endl;
system("pause");
return 0;
}
#include <cstdio>
#include <iostream>
using namespace std;
int main(){
int n, kolvo=0;//заводим переменную n и переменную kolvo, отвечающую за количество купюр
cout << "Enter n:\n"; cin >> n;//сканируем эту переменную
if (n > 64){
kolvo += n / 64;
n %= 64;
}
if (n > 32){
kolvo += n / 32;
n %= 32;
}
if (n > 16){
kolvo += n / 16;
n %= 16;
}
if (n > 8){
kolvo += n / 8;
n %= 8;
}
if(n > 4){
kolvo += n / 4;
n %= 4;
}
if (n > 2){
kolvo += 1;
n %= 2;
}
if (n == 1){
kolvo += 1;
}
cout <<"There's the number:\n"<< kolvo;
return 0;
}
P.S.:думаю понятно, почему последние два if' а отличаются, но если остались вопросы, то пишите!