В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Apelsinka0986
Apelsinka0986
02.01.2021 03:38 •  Информатика

Написать программу решения : вводить целые числа с клавиатуры, пока не будет введен ноль. а) найти сумму введенных чисел. b) найти количество четных отрицательных чисел среди введенных. c) найти максимальное число среди введенных.

Показать ответ
Ответ:
Rita210606
Rita210606
14.08.2020 19:53
//PascalABC.Net 3.2
begin
var max:=-1000000000;
var sum:=0; var count:=0; var a:=0;
repeat
a:=readinteger('Введите число: ');
if (a.IsEven) and (a<0) then inc(count);
if a>max then max:=a;
sum+=a;
until a=0;
writeln ('a) ', sum);
writeln ('b) ', count);
write  ('c) ', max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота