В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Dec3mber
Dec3mber
25.01.2021 07:59 •  Информатика

Написать программу с циклом for для подсчета кубов чисел от 1 до N
PascalABC.NET 8 класс.

Показать ответ
Ответ:
lubova1984
lubova1984
23.02.2020 18:25
количество используемых знаков для шифровки 2 (· и -)
с знака можно зашифровать 2 сигнала, а именно: · и -
с знаков можно зашифровать 4=2² сигнала, а именно: · ·, · -, - · и - -
с знаков можно зашифровать 8=2³ сигнала, а именно: · · ·, · · -,
· - ·, - · ·, - - ·, - · -, · - - и - - -
с знаков можно зашифровать 16=2^4 сигнала, а именно: · · · ·,
· · · -, · · - ·, · · - -, · - · ·, · - · -, · - - ·, · - - -, - · · ·, - · · -, - · - ·, - · - -, - - · ·, - - · -,
- - - · и, наконец, - - - -

для нахождения количества символов, закодированных с точки и тире длиной не менее (два и более) двух и не более четырех (четыре и менее) сигналов, необходимо сложить возможные варианты их:
2²+2³+2^4=4+8+16=28
0,0(0 оценок)
Ответ:
LiNkoLine
LiNkoLine
23.03.2020 02:46
1.

program xopow1;
   uses   crt;
   var  
 a, b, Sek: integer;  
begin  
writeln('Введите границы:');  
repeat    
readln(a, b);  
until b >= a;  
 clrscr;  
for a := a to b do
    begin    
Sek := a * 60;    
writeln(a, ' мин. = ', sek, ' сек.')  
end
end.

2.

program xopow2;
  uses crt; 
Var
 z:integer;
 f,x,y:real; 
Begin 
clrscr; 
Writeln;
X:=10000;
Y:=(x/100)*10;
for z:=1 to 7 do 
 Begin 
X:=x+y; 
Writeln(Z,' -й день тренировок спортсмен пробежал ',X:3:2,' Км.'); 
End; 
Writeln('Нажмите Enter...'); 
Readln; 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота