В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Лина5678
Лина5678
30.09.2021 11:22 •  Информатика

написать программу. составить блок схему. вставить заданное число в массив целых чисел перед последним четным элементом.

Показать ответ
Ответ:
LineyNikki
LineyNikki
08.07.2020 08:36
Const
    m = 10; 
var
    a: array[1..m+1] of integer;
    i, k: integer;
begin     
write ('Исходный массив: ');   
for i := 1 to m do
  begin
  a[i] := random(100);
  write (a[i],'; ');
  end;   
writeln; 
write('Введите число: ');
readln(k);
for i:=m+1 downto 1 do
  begin
  a[i]:=a[i-1];
  if a[i] mod 2=0 then
    begin
    a[i-1]:=k;
    break;
    end;
  end;
write('Измененный массив: ');  
for i := 1 to m+1 do
         write (a[i],'; ');  
end.
написать программу. составить блок схему. вставить заданное число в массив целых чисел перед последн
написать программу. составить блок схему. вставить заданное число в массив целых чисел перед последн
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота