В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Smartfone
Smartfone
25.10.2022 06:16 •  Информатика

Написать программу в Pascal: Найти сумму квадратов всех целых чисел от а до b (значение а и b вводятся с клавиатуры, b больше а).​

Показать ответ
Ответ:
Sofwork
Sofwork
20.09.2020 01:01

program skab;

uses

crt;

var

i, a, b, s: integer;

begin

s := 0;

writeln('Введите a, затем b (a<b) :');

readln(a, b);

if a < b then

begin

for i := a to b do

s := s + (i * i);

writeln('Сумма квадратов целых чисел от а до b: ', s);

end

else

writeln('Ошибка! Проверьте правильность введённых данных! Закрытие программы...');

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота