В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
anasteishamrrr
anasteishamrrr
02.01.2020 20:52 •  Информатика

Написать программу (в паскаль) , которая вводит число и выводит ее половину, четверть, одну восьмую, одну шестнадцатую.​

Показать ответ
Ответ:
KerimovaLuiza919
KerimovaLuiza919
28.05.2020 23:56

1 Вариант без использования цикла

program delenie1;

var a:real;

begin

write('Введите число: ');

readln(a);

writeln('Половина: ', a/2);

writeln('Четверть: ', a/4);

writeln('Одна восьмая: ', a/8);

writeln('Одна шестнадцатая: ', a/16);

end.

2 Вариант с использованием цикла

program delenie2;

var a:real;

i:integer;

begin;

write('Введите число: ');

readln(a);

for i:=1 to 4 do

 begin

 a:= a/2;

 writeln(a);

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота