В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ЮляLoveYou
ЮляLoveYou
10.07.2021 09:25 •  Информатика

Написать программу в паскале : символы, стоящие на четных местах заменить на *. пользоваться можно только: pos,insert,delete,length,copy

Показать ответ
Ответ:
Августина3008
Августина3008
24.05.2020 04:16

чесно говоря без них куда легче

 

var s:string;

i:integer;

Begin

  read(s);

  for i:= 1 to length(s) do

    if i mod 2 = 0 then s[i]:='*';

  writeln(s);

End.

 

с ними только больше кода

 

var s:string;

i:integer;

Begin

  read(s);

  for i:= 1 to length(s) do

    if i mod 2 = 0 then begin

      Delete(s,i,1);

      Insert('*',s,i);

    end;

  writeln(s);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота