В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Assssssa
Assssssa
02.07.2021 13:25 •  Информатика

Написать программу в паскале(строковые и символьные величины)

вводится предложение из 2-х одинаковых по длине слов. вывести на экран большее из них.

нужно!

Показать ответ
Ответ:
JetBalance97
JetBalance97
21.06.2021 23:41

ответ:Привет,я не знаю Паскаль,но объяню логику решения. Решение максимально простое и не требует каких-либо углубленных знаний.

Объяснение:

короч. Для каждой цифры ты берешь переменную(x; y; z) дальше пишешь,если x=z,то это число является палиндромом,если x≠z,то начинаешь прибавлять по единице к z, если z = 10 то пусть будет равно 0,дальше прибавляешь к x +1 и делаешь,то же самое с z и все. реализовать просто используя несколько циклов и все. Удачи

Есть вообще капец творческое решение. ты просто из x-z,если число положительное то прибавляешь в z и все,если 0,то тут пишешь yes,если отрицательное,например, -3,то отнимаешь от x ,тоесть x--3=x+3 и все

Я сейчас увидел код от паскаля(человек сверху написал),ахахаххаха, это что за мусор,а не язык,я,конечно,не полностью понял код,но если ты просто будешь прибавлять по единице к трехзначному числу,то это будет долго и не эффективно,хотя и не прям уж ужасно,так что дерзай,но блин выбрось паскаль и начни с нормальных языков,которые пригодятся.

0,0(0 оценок)
Ответ:
Petrov7771
Petrov7771
27.05.2021 08:43

program five;

var

 number, quantity: integer;

begin

 quantity := 0;

 read(number);

 while number > 0 do

 begin

   if (number mod 10 mod 5 = 0) then

     inc(quantity);

   number := number div 10;

 end;

 write(quantity);

end.

Объяснение:

program five;  // Название программы

var

 number, quantity: integer;  // Целочисленные переменные:

number - вводимое с клавиатуры число;quantity - количество цифр кратных 5.

begin  // Начало программы

 quantity := 0;  // Количество цифр = 0

 read(number);  // Ввод числа с клавиатуры

 while number > 0 do  // Пока значение переменной number > 0

 begin  // Начало цикла

   if (number mod 10 mod 5 = 0) then  // Если последняя цифра переменной number (number mod 10) при делении на 5 дает остаток 0, тогда

     inc(quantity);  // Прибавляем к переменной quantity единицу

   number := number div 10;  // Удаляем последнюю цифру числа

 end;  // Конец цикла

 write(quantity);  // Вывод ответа

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота