В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
malinka151
malinka151
11.12.2022 08:49 •  Информатика

Написать программу в паскале. входные данные : вводятся 4 числа, а, b, c, d выходные данные : найдите все целые решения уравнения ax^3+bx^2+cx+d=0 на отрезке [0,1000] и выведите их в порядке возрастания. если на данном отрезке нет ни одного решения, то ничего выводить не нужно.

Показать ответ
Ответ:
torshindanya
torshindanya
07.10.2020 20:15
//PascalABC.NET
//Версия 3.3, сборка 1611 (06.01.2018)

begin
  var (a,b):=ReadInteger2('Введите a,b,c,d->');
  var (c,d):=ReadInteger2;
  Write('Корни: ');
  for var x:=0 to 1000 do
   if a*x**3+b*x**2+c*x+d=0 then Write(x,' ');
end.

Пример:
Введите a,b,c,d-> 1 -3 -13 15
Корни: 1 5 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота