В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
simakanna
simakanna
15.04.2021 09:42 •  Информатика

Написать программу, вводящую с клавиатуры целые числа и вычисляющую их сумму до тех пор, пока эта сумма не станет больше 1000. В этом случае программа должна напечатать вычисленную сумму и завершиться. (С программы Java)

Показать ответ
Ответ:
nastaklimenkofll
nastaklimenkofll
29.11.2020 12:02

import java.util.Scanner;

public class Main{

   public static void main(String[] args) {

       Scanner sc = new Scanner(System.in);

       int sum = 0, x;

       while(sum <= 1000){

           x = sc.nextInt();

           sum = sum + x;

       }

       System.out.println(sum);

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота