В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
2407arinka
2407arinka
09.03.2023 21:41 •  Информатика

Написать программу вычисления стоимости покупки. нужно указать вид товара, его цену и количество. вид экрана во время работы программы: вычисление стоимости покупки. введите исходные данные: какой товар вы покупаете? -> тетрадь по какой цене? -> 1.50 сколько штук? -> 5 ваш товар - тетрадь. стоимость покупки: 7.50 сколько денег даете? -> 10 ваша сдача: 2.5

Показать ответ
Ответ:
swordfishtrombone
swordfishtrombone
20.07.2020 16:17
Var money, cost,summa : real;
count : integer;
 tovar: string;
begin writeln('Введите исходные данные: ');
  writeln('Какой товар вы покупаете? ');
 readln(tovar);
  writeln('По какой цене? ');
 readln(cost);
  writeln('Сколько штук? ');
 readln(count);
  summa := cost*count; writeln('Ваш товар - ', tovar, '. Стоимость покупки: ',summa:0:2);  writeln('Сколько денег даете? ');
 readln(money);
  if money=summa then writeln('свободен, под расчёт') else if money > summa then writeln('Ваша сдача: ', money-summa) else writeln('Нужно добавить: ', summa-money,. ');
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота