Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
уфагаполмилио
03.07.2020 20:55 •
Информатика
Вмассиве a[100] найти среднее арифметическое, кратных 5 и кратных 3 элементов массива.
Показать ответ
Ответ:
wEnD11
07.07.2020 16:47
var
i,n:integer;
p:real;
a:array[1..100]of integer;
begin
for i:=1 to 100 do
begin
a[i]:=random(50)+1;
write(a[i],' ');
if (a[i] mod 5=0) and (a[i] mod 3=0) then
begin
p:=p+a[i];
n:=n+1;
end;
end;
writeln;
p:=p/n;
writeln('ответ: ',p);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
LOL2017Alex
18.01.2020 02:23
Перечислите не менее пяти известных вам устройств внешней памяти....
kivonen3p08qoq
30.03.2021 06:15
Scratch меняет фон 3 раза алгоритм ...
АляМиткалова
09.08.2020 12:39
Для заданной функции r=tg(sqrt(2,(b) вывести на экран значения функции,которые меньше -1,6 и соответсвеющие им значения аргумента на отрезке b∈[1; c] с шагом h=0,2. надо...
кристинка0051
09.08.2020 12:39
Количество цветов, воспроизводимых в графическом изображении равно 4. разрешение графического изображения 512*64 точек. минимальный объем памяти для хранения графического...
Ника3515
09.08.2020 12:39
Ввелокроссе участвуют 312 спортсменов. специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая его номер с использованием...
mrzadvorgetski
09.08.2020 12:39
Чотири дівчинки їли мандарини. ганнуся зїла більше, ніж юля іринка- більше ніж леся але менше ніж юля розстав імена дівчаток у порядку зростання кількості мандаринів...
help276
09.08.2020 12:39
Вшкольной библиотеке книги расставлены 16 стеллажах. в каждом стеллаже - 4 полки. какое количество информации (в битах) получит петя, узнав в каком стеллаже и на какой...
SamDem
26.03.2020 04:20
Напишите программу, которая для последовательности целых чисел определяет количество четных чисел. программа получает на вход количество чисел в последоввтельности, а...
viktoria123987650
19.02.2020 07:31
Сообщение о мониторе жидкокристалическом и т.д. 5 класс...
sonikzets
19.02.2020 07:31
Уже надо завтро сдавать тетрать написать прогу которая находит произведение элемента массива...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i,n:integer;
p:real;
a:array[1..100]of integer;
begin
for i:=1 to 100 do
begin
a[i]:=random(50)+1;
write(a[i],' ');
if (a[i] mod 5=0) and (a[i] mod 3=0) then
begin
p:=p+a[i];
n:=n+1;
end;
end;
writeln;
p:=p/n;
writeln('ответ: ',p);
end.