В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
olegtab34
olegtab34
02.08.2021 04:27 •  Информатика

Написать программу вычисления значения функции икс равно двенадцати а квадрат плюс семь а минус шестнадцать

Показать ответ
Ответ:
PaFaS123
PaFaS123
08.10.2020 06:11
Значение полиномов эффективно вычислять не "в лоб", а с использованием схемы Горнера.
x = 12a² + 7a - 16 = -16 + a(7 + 12a)

PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadReal('a=');
  var x:=-16+a*(7+12*a);
  Writeln('x=',x)
end.

Пример
a= 5.18
x=342.2488
0,0(0 оценок)
Ответ:
H3RURG
H3RURG
08.10.2020 06:11
Var a,x: Integer;
begin
writeln('Введите значение числа a');
readln(a);
x:=12*(a*a)+7*a-16;
writeln('ответ: x=',x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота