В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
milenairk38
milenairk38
23.01.2022 19:29 •  Информатика

Написать программу вычисляющую время в годах, через которое банковский вклад s увеличится в n раз, и сумму выплат по процентам, если каждый год на него начисляются p процентов годовых и проценты капитализируются.

Показать ответ
Ответ:
larsab
larsab
10.05.2022 00:37
Задача, аналогичная той, которую публиковали вчера. Только цикл repeat заменяем на while.

Сначала немного математики.
\displaystyle a_n= \frac{n!}{(2n)!}=\frac{\prod_{i=1}^ni}{\prod_{i=1}^{2n}i}=\frac{\prod_{i=1}^ni}{\prod_{i=1}^{n}i\times\prod_{i=n+1}^{2n}i}=\frac{1}{\prod_{i=n+1}^{2n}i}; \quad n\in\mathbb N
О модуле тут смысла нет говорить, поскольку все an - суть положительные величины на интервале (0;1).

uses Crt;

function ai(n:integer):real;
var
  i:integer;
  p:real;
begin
  p:=1;
  for i:=n+1 to 2*n do p:=p*i;
  ai:=1/p
end;

var
  i:integer;
  eps,s,an:real;
begin
  ClrScr;
  Write('eps='); Read(eps);
  s:=0; i:=1; an:=eps+1;
  while an>=eps do begin
     an:=ai(i);
     if an>=eps then begin s:=s+an; Inc(i) end
  end;
  Writeln('s=',s);
  ReadKey
end.

Тестовые решения:
eps=0.07
s= 5.8333333333E-01

eps=0.000001
s= 5.9229647667E-01

eps=1e-8
s= 5.9229653448E-01

Для контроля результата можно отметить, что сумма первых 1000 членов ряда равна приблизительно 5.922965365Е-01

Если раздражает наличие функции, можно и без нее:
uses Crt;

var
  i,j:integer;
  eps,s,an,p:real;
begin
  ClrScr;
  Write('eps='); Read(eps);
  s:=0; i:=1; an:=eps+1;
  while an>=eps do begin
    p:=1;
    for j:=i+1 to 2*i do p:=p*j;
    an:=1/p;
    if an>=eps then begin s:=s+an; Inc(i) end
  end;
  Writeln('s=',s);
  ReadKey
end.
0,0(0 оценок)
Ответ:
Aliiev19
Aliiev19
21.10.2021 00:29
Вопрос №1:   1) - г                       2) - а                       3) - б                       4) - д                       5) - в вопрос №2: 1) - б                       2) - в                       3) - а                       4) - д                       5) - г вопрос №3: в,г вопрос №4: для ответа на этот вопрос необходимы картинки из условия, так что ответить без них не представляется возможным. вопрос №5: в вопрос №6: д вопрос №7: 1) - г                       2) - в                       3) - а                       4) - д                       5) - б вопрос №8: 1) - б                       2) - а                       3) - в вопрос №9: здесь,как и в вопросе №4 решающую роль играет рисунок,которого нет - ответа без него быть не может. вопрос №10: а,б,д вопрос №11: в -  информационные компьютерные технологии с одновременным использованием нескольких видов информации.вопрос №12: все 3 варианта ответа имеют место быть верными, то есть все варианты верны.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота