В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
skirtachmaksim
skirtachmaksim
14.06.2021 00:56 •  Информатика

Написать программу, вычисляющюую значение у, если значение х вводиться с клавиатуры. Результат выдать на экран. У={41х-18,
{9х^7-8х^5+13х^2+157
5/32х^2-5х^2+317
При х меньше -4
При -4 меньше либо равно х меньше либо равно 14
Иначе

Показать ответ
Ответ:
Relig1d
Relig1d
05.07.2020 14:20
Вся информация, которую обрабатывает компьютер должна быть представлена двоичным кодом с двух цифр 0 и 1. Эти два символа принято называть двоичными цифрами или битами. С двух цифр 0 и 1 можно закодировать любое сообщение. Это явилось причиной того, что в компьютере обязательно должно быть организованно два важных процесса: кодирование и декодирование.Кодирование – преобразование входной информации в форму, воспринимаемую компьютером, т.е. двоичный код.Декодирование – преобразование данных из двоичного кода в форму, понятную человеку.С точки зрения технической реализации использование двоичной системы счисления для кодирования информации оказалось намного более простым, чем применение других
0,0(0 оценок)
Ответ:
1sanita
1sanita
22.01.2023 05:11
1.

program raf105;

var a,b,c:integer;

begin

write('Введите 3 числа: ');

readln(a,b,c);

if (a<b) and (a<c)

 then writeln('Произведение 2 наибольших чисел: ',b*c);

if (b<a) and (b<c)

 then writeln('Произведение 2 наибольших чисел: ',a*c);

if (c<b) and (c<a)

 then writeln('Произведение 2 наибольших чисел: ',b*a);

end.

2.а)

program raf105;

var a,i,b:integer;

begin

write('Введите число: ');

readln(a);

for i:=1 to a do

 if ((a mod i)=0) and ((i mod 2)<>0)

   then b:= b+i;

writeln('Сумма нечётных делителей введённого числа: ',b);

end.

б)

program raf105;

var a,a2,i,j,b:integer;

begin

write('Введите меньшее число: ');

readln(a);

write('Введите большее число: ');

readln(a2);

for j:=a to a2 do

begin

 for i:=1 to j do

   if ((j mod i)=0) and ((i mod 2)<>0)

     then b:= b+i;

writeln('Сумма нечётных делителей числа ',j,' равна: ',b);

b:= 0;

end;

end.

Язык программирования PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота