В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kseniafilipovich09
kseniafilipovich09
27.06.2022 13:08 •  Информатика

Написать программу. Заполнить массив случайными числами на отрезке [-5;10], вывести его на экран,
подсчитать кол-во четных чисел в нем
pascal

Показать ответ
Ответ:
Аккаунт удален
Аккаунт удален
27.09.2022 16:18

C++

#include <iostream>

#include <ctime>

using namespace std;

int main() {

setlocale(LC_ALL, "Russian");

srand(time(NULL));

int arr[20],sum=0;

for (int i = 0; i < 20; i++)

{

 arr[i] = rand() % 36+(-15);

}

cout << "Обычный массив -> ";

for (int i = 0; i < 20; i++)

{

 cout << arr[i] << "  ";

}

cout << endl << "Элементы массива которые больше 10 ->";

for (int i = 0; i < 20; i++)

{

 if (arr[i]>10) {

  cout << arr[i] << "  ";

 }

}

cout << endl;

 system("pause");

 return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
29Vladislava13
29Vladislava13
06.02.2022 13:34

с++

#include <iostream>

#include <ctime>

using namespace std;

int main() {

srand(time(NULL));

int arr[10],sum=0;

for (int i = 0; i < 10; i++) //заполнение массива  

{

 arr[i] = rand() % 100;

}

for (int i = 0; i < 10; i++) //вывод массива

{

 cout << arr[i] << "\t";

}

cout << endl;

for (int i = 0; i < 10; i++) //узнаем кратность чисел

{

 if (arr[i] % 4 == 0) {

  sum = sum + arr[i];

 }

}

cout << sum << endl;

 system("pause");

 return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота