Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Five11
04.05.2020 18:32 •
Информатика
Написать рекурсивную программу вывода на экран следующей картинки: 1111111111111111 (16 раз) 222222222222 (12 раз) 33333333 (8 раз) 4444 (4 раза) 33333333 (8 раз) 222222222222 (12 раз) 1111111111111111 (16 раз)
Показать ответ
Ответ:
Alinahe2001
31.08.2020 12:55
Procedure p(k:integer);
var i:integer;
begin
for i:=1 to 20-4*k do write(k);
writeln
if k<4 then
begin
p(k+1);
for i:=1 to 20-4*k do write(k);
writeln;
end;
end;
begin
p(1);
end.
Результат:
1111111111111111
222222222222
33333333
4444
33333333
222222222222
1111111111111111
0,0
(0 оценок)
Популярные вопросы: Информатика
12рок1
14.05.2022 07:00
1) Информационное сообщение объемом 500 бит содержит 100 символов. Какова мощность алфавита? 2) Сколько символов содержит информационное сообщение, записанное с символьного алфавита,...
polosa48rus
26.05.2023 07:25
2. Даны два простых высказывания: А={2*2=4}, B={2*2=5}. Решите составное высказывание: (A&B)v(Av(A&B))....
turabovrenat
22.11.2021 05:40
Вариант №6 1) дана таблица [ 3,5]. определите сумму элементов, стоящих в четных строках. 2) дана таблица [ 2,4]. каждый элемент таблицы увеличить в 3 раза, организовав полученные...
alinaara
17.06.2021 03:45
Записать в развернутом виде числа а) а10=125,34 б) а8=125,34 2. перевести в десятичную а) а8=341 б) а6=341 3 перевести целые числа из десятичной системы счисления в двоичную...
aikosha9
23.06.2022 13:07
Список групп содержит название группы, количество студентов в каждой группе, количество 5, 4, 3. предусмотреть правильность ввода. рассчитать количество двоек, процент неуспевающих...
nikitaevaoa
01.02.2022 23:11
Составьте сценарий для компьютерной игры...
лллаал
16.04.2022 06:31
Например 220результат 10 22...
juliadzyombak
27.09.2021 05:03
Середовище розробки проєктів Python IDLE складається з. 1)Текстового редактора.2) Інтерпретатора.3) Компілятора.4) Засобів налагодження проєкту для пошуку в ньому помилок.5)...
Dima1Tap
04.02.2022 04:27
, просто задача и не код) Реши следующую задачу: Магир, Рашид, Нармина и Гюнай пошли в кинотеатр. Они решили попробовать сесть на стулья разными . Сколько существует рассадки...
Dasha16082678
17.08.2020 23:33
, язык Python 7 класс, 4 задачки...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var i:integer;
begin
for i:=1 to 20-4*k do write(k);
writeln
if k<4 then
begin
p(k+1);
for i:=1 to 20-4*k do write(k);
writeln;
end;
end;
begin
p(1);
end.
Результат:
1111111111111111
222222222222
33333333
4444
33333333
222222222222
1111111111111111