Написать в паскале 111. мышонок джерри улепетывает к своей норке по прямой. успеет ли кот том догнать джерри, если джерри находится как раз на полпути между томом и норкой? 118. даны коэффициенты квадратного уравнения a,b,c. найти действительные корни этого уравнения. 122. можно ли прямоугольный пакет размерами a,b,c положить в чемодан размерами x,y,z? 123.составить программу вычисления значения функций: а)1 при x> = 0; y=0 при x< 0 б)x^2 при x> 0 y=-x при x< =0 в)1 при x> =1 y=0 при -11 y=0 при -1< =x< =1 x+1 при x< -1
program Kv_ur;
var a,b,c,x1,x2,D: real;
begin
Writeln ('Для решения квадратного уравнения');
Writeln ('Введите коэффициент a');
Readln (a);
Writeln ('Введите коэффициент b');
Readln (b);
Writeln ('Введите коэффициент c');
Readln (c);
D:=Sqr(b)-4*a*c;
If d<0 then Writeln ('Так как дискрименант ',D,'<0 уравнение не имеет решений');
begin
If d=0 then
begin
x1:=-b/(2*a);
Writeln ('Так как дискриминант равен 0 уравнение имеет один корень:');
Writeln(x1);
end;
If d>0 then
begin
x1:=(-b- Sqrt(Sqr(b)-4*a*c))/2*a;
x2:=(-b+ Sqrt(Sqr(b)-4*a*c))/2*a;
Writeln ('Так как дискриминант ',D,'>0 уравнение имеет два корня:');
Writeln ('x1=', x1, ' и x2=', x2);
end;
end;
end.
122. Можно ли прямоугольный пакет размерами A,B,C положить в чемодан размерами X,Y,Z?
program chemodan;
var a,b,c,x,y,z: real;
begin
Writeln ('введите размеры пакета');
Writeln ('Введите длину a');
Readln (a);
Writeln ('Введите ширину b');
Readln (b);
Writeln ('Введите высоту c');
Readln (c);
Writeln ('введите размеры чемодана');
Writeln ('Введите длину х');
Readln (x);
Writeln ('Введите ширину y');
Readln (y);
Writeln ('Введите высоту z');
Readln (z);
If (a<=x) and (b<=y) and (c<=z) then Writeln ('пакет можно положить')
else Writeln ('пакет положить нельзя');
End.