Написать в питоне! 1) Введите функцию Python, чтобы найти максимум три числа
2) Чтобы вычислить сумму всех чисел в списке, напишите функцию на Python. Даны числа: 2,3,5,4
3) Чтобы вычислить произведение всех чисел в списке, напишите функцию на Python. Даны числа: 2,3,5,4 4) Вам нужно написать программу, которая вычисляет наибольший общий делитель четырех натуральных чисел.
i,j,s:integer;
begin
for i:=1 to 4 do
for j:=1 to 4 do
readln(a[i,j]);
for i:=1 to 4 do begin
writeln();
for j:=1 to 4 do begin
write(a[i,j],' ');
if (i+j>5) then s:=s+a[i,j];
end;
end;
writeln();
write(s);
end.
2)var a:array[1..4,1..4] of integer;
i,j,s:integer;
begin
for i:=1 to 4 do
for j:=1 to 4 do
readln(a[i,j]);
for i:=1 to 4 do begin
writeln();
for j:=1 to 4 do begin
write(a[i,j],' ');
if (i>J) then s:=s+a[i,j];
end;
end;
writeln();
write(s);
end.
begin
readln(t);
readln(k);
for j := 0 to 1 do begin
if (j = 1) then writeln();
for i := 0 to 9 do begin
if(j = 0) then begin
mas1[i] := random(100);
write(mas1[i], ' ');
if mas1[i] > t Then mas1[i] := mas1[i] + 4;
end
else
begin
mas2[i] := random(100);
write(mas2[i], ' ');
if mas2[i] > 10 * K Then
mas2[i] := mas2[i] + K;
end;
end;
for i := 0 to 9 do
if (j = 0) then
write(mas1[i])
else
write(mas2[i]);
writeln();
end;
readln();
end.
))