В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Jeka5A
Jeka5A
27.08.2022 15:54 •  Информатика

Напишите программу для решения следующей .девятиклассники участвовали в викторине по . необходимо было ответить на 20 вопросов. победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. на сколько вопросов победитель ответил правильно? если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите yes, иначе выведите no. гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов.программа получает на вход число участников викторины n (1 ≤ n ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ. пример работы программы: входные данные 4 15 12 0 17 выходные данные 17 yes

Показать ответ
Ответ:
kskdosms
kskdosms
01.10.2020 18:12
Var
    i, k,n, max: integer;
    f:boolean;

begin
    readln(k);
    for i := 1 to k do
    begin
        readln(n);
        if (i = 1) or (max < n) then
            max := n;
        f:=f or (n=0);
    end;
    writeln(max,' ', f);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота