В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ferklo
Ferklo
04.06.2020 07:56 •  Информатика

Напишите программу для решения следующей задачи. Девятиклассники участвовали в
викторине по математике. Необходимо было ответить на 20 во Победителем
викторины считается участник, правильно ответивший на наибольшее количество во На сколько во победитель ответил правильно? Если есть участники викторины,
которые не смогли дать правильный ответ ни на один из во выведите YES, иначе
выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из
во Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для
каждого участника вводится количество во на которые получен правильный ответ.

На языке Пайтон

Показать ответ
Ответ:
olga877
olga877
07.10.2022 11:01
Поскольку в условии не сказано, включать ли в множество повторяющиеся символы, принято решение для простоты их включать.

const
  nn = 100;{максимальная мощность множества}

var
  m: array[1..nn] of char;
  i, n, n1: integer;
  s1, s2: string;
  alpha, digit: set of char;

begin
  alpha := ['А'..'я'];
  digit := ['0'..'9'];
  n := 0;
  Writeln('Введите строку символов первого множества');
  Readln(s1);
  Writeln('Введите строку символов второго множества');
  Readln(s2);
  for i := 1 to Length(s1) do
    if (s1[i] in alpha) then begin n := n + 1; m[n] := s1[i] end;
  for i := 1 to Length(s2) do
    if (s2[i] in digit) then begin n := n + 1; m[n] := s2[i] end;
  Writeln('Результирующее множество');
  for i := 1 to n do Write(m[i]:2)
end.

Тестовое решение:
Введите строку символов первого множества
-This 1*2 П*ро=изvolnый наbop сим;волob**
Введите строку символов второго множества
Отсюда 1-(4)=5 только цифры 33.634 berem
Результирующее множество
 П р о и з ы й н а с и м в о л 1 4 5 3 3 6 3 4
0,0(0 оценок)
Ответ:
svetaredkina
svetaredkina
21.07.2020 09:56
#include <iostream>
#include <conio.h>
#include <time.h>
using namespace std;

void main()
{
 srand(time(NULL));
 setlocale(0, "");
 int arr[17];
 int a, b, chet=0, nechet = 0;
cout << "Введите диапазон ." << endl << "Нижняя граница диапазона: "; cin >> a; cout << "Верхняя граница диапазона: "; cin >> b; cout << endl;
for (int i = 0; i < 17; ++i)
{
  arr[i] = a + rand() % (b-a+1);
  cout <<" "<<arr[i];
}
for (int i = 0; i < 17; ++i)
{
  if (arr[i] % 2 == 0) chet++;
 else nechet++;
} if (chet > nechet)
 cout << " \n Четных больше";
else if (nechet>chet)
 cout << "\n Нечетных больше";
else cout << "\n Одинаковое количество четных и нечетных";
 _getch();
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота