В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Дурашка008
Дурашка008
05.11.2020 20:32 •  Информатика

Напишите программу для систематизации должностных обязанностей странствующих рыцарей. Формат ввода Вводятся строки обязанностей рыцаря. Формат вывода Через точку с запятой и пробел вывести обязанности без повторений в алфавитном порядке.(python)

Показать ответ
Ответ:
MiraQeen
MiraQeen
29.04.2021 00:43
Var a:array of array of integer;
c:array of array of integer;
ma:array of array of integer;
i,j,n:integer;
begin;
randomize;
readln(n);
setlength(a,n+1); //задаём размерность динамических массивов
setlength(c,n+1);
setlength(ma,n+1);
for i:=1 to n do
begin;
setlength(a[i],n+1);
setlength(c[i],n+1);
setlength(ma[i],n+1);
end;

writeln('Matrix A:');   //генерируем массив псеводслучайных чисел
for i:=1 to n do begin;
 writeln;
  for j:=1 to n do
   begin;
    a[i,j]:=random(10);
    write(a[i,j]:4);
   end;
 end;
writeln;

writeln('Matrix C:'); //аналогично
for i:=1 to n do
 begin;
 writeln;
  for j:=1 to n do
   begin;
    c[i,j]:=random(10);
    write(c[i,j]:4);
   end;
 end;

for i:=1 to n do     //сохраняем матрицу C для транспонации
  for j:=1 to n do
    ma[i,j]:=c[i,j];
    writeln;

writeln('Transpose matrix C:'); //транспонируем C
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     c[i,j]:=ma[j,i];
     write(c[i,j]:4);
    end;
 end;

writeln;
writeln('Final matrix:'); // получаем финальную матрицу
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     ma[i,j]:=2*c[i,j]*a[i,j];
{по свойству дистрибутивности матриц С(A+A)=C*A+C*A=2*C*A}
     write(ma[i,j]:4);
    end;
 end;
end.
0,0(0 оценок)
Ответ:
Zxc1asdqwe
Zxc1asdqwe
30.09.2020 00:37
var a: array[1..2,1..4] of real;
    b,c: string; 
    d,x,y: real;
    i,j: integer;
begin
   b:='ABCD';  c:='xy';
   writeln('трапеция ABCD');
   for i:=1 to 4 do
   begin
     writeln('координаты точки ',b[i],': ');
     for j:=1 to 2 do
     begin
       write('   ',c[j],i,' = ');
       readln(a[j,i]);
     end;  
   end;  
   x:=(a[1,3]-a[1,2]+a[1,4]-a[1,1])/2;
   y:=(a[2,3]-a[2,2]+a[2,4]-a[2,1])/2;
   d:=sqrt(x*x+y*y);
   writeln('длина средней линии:  ',d:5:2);
end.

ввод - вывод

трапеция ABCD
координаты точки A: 
   x1 = 3
   y1 = 2
координаты точки B: 
   x2 = 5
   y2 = 5
координаты точки C: 
   x3 = 9
   y3 = 5
координаты точки D: 
   x4 = 10
   y4 = 2
длина средней линии:   5.50
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота