Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Владислава3188125
29.05.2023 22:14 •
Информатика
Напишите программу для записи четырехзначного числа в обратном порядке. например: 2451--> 1542 паскаль.
Показать ответ
Ответ:
katyakot56806
07.10.2020 20:59
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
ReadInteger().ToString().Reverse().Select(x->x.ToDigit()).Println('');
end.
0,0
(0 оценок)
Ответ:
Аня20171502
07.10.2020 20:59
Var n,m: integer;
begin
write('n = '); readln(n);
m:=0;
repeat
m:=m*10+(n mod 10);
n:=n div 10;
until n=0;
writeln(m);
end.
n = 2456
6542
0,0
(0 оценок)
Популярные вопросы: Информатика
nicecherry23
10.11.2021 15:32
Паскаль. написать функцию, находящую максимальное из двух вещественных чисел и с её определить максимальное из 4-х вводимых с клавиатуры вещественных чисел....
vovabondar28
04.01.2021 12:33
Тренер сообщил, что группа будет плавать по дорожке номер 3, при этом школьники получили 2 бита информации. сколько дорожек в бассейне?...
safiya250707
23.09.2020 12:26
Составить ребус на тему : диск, флешка , носитель...
Alan1987
23.09.2020 12:26
Племя мульти имеет 32-символьный алфавит. письмо, которое написал вождь племени, содержало 80 символов. какое количество информации содержит это письмо? ( напишите...
UlyanaKwon666
24.05.2020 11:19
Сколько бит памяти займет словово каталог...
misha99672
24.05.2020 11:19
Составить программу нахождения по формуле герона...
lika369
24.05.2020 11:19
Вкоробке лежат 64 разноцветных карандаша какое кол-во информации содержит сообщение что из коробки достали красный карандаш?...
миша29112000
13.05.2022 05:59
Скорость передачи данных по некоторому каналу равна 64000 бит в секунду передача файла по этому каналу связи заняла 16 секунд определите размер файла в килобайтах...
milknastas
26.04.2020 03:38
Какое количество информации получит игрок при первом ходе другово игрокв в игре морской бой на поле...
ринат127
19.08.2022 23:53
Вячейке e4 находится формула ($c$3+c5) /d6. как она изменится при переносе этой формулы в ячейку f7; d8....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Версия 3.3, сборка 1611
begin
ReadInteger().ToString().Reverse().Select(x->x.ToDigit()).Println('');
end.
begin
write('n = '); readln(n);
m:=0;
repeat
m:=m*10+(n mod 10);
n:=n div 10;
until n=0;
writeln(m);
end.
n = 2456
6542