В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Vita0814
Vita0814
04.01.2023 01:56 •  Информатика

Напишите программу и подгрузите файл(можно в текстовом редакторе, можно в программе, а потом скопируйте в текстовый файл, можно на бумаге, дальше через фото) Ваша программа ввести число. Это число увеличивается в 12 раз и выводится.

Показать ответ
Ответ:
kodraemail
kodraemail
16.09.2022 10:50
ИСПРАВЛЕНО
---
Uses crt;
{описание переменных}
var a,b,c: array [1..20] of integer;
    x,sum:integer;
begin
     sum:=0; {обнуляем сумму}
     for x:=1 to 20 do {включаем цикл ввода массивов}
     begin
          write('a[',x,']:'); {вывод текста на экран}
          readln(a[x]); {ввод массива А}
          write('b[',x,']:'); {вывод текста на экран}
          readln(b[x]); {ввод массива В}
          c[x]:=a[x]+b[x]; {формируем массив С}
          if x mod 2=0 then
             sum:=sum+c[x];
     end;
     writeln; {переводим указатель на новую строку}
     for x:=1 to 20 do {цикл вывода массива С}
         writeln('c[',x,']:',c[x]); {вывод текста на экран}
     writeln('sum=',sum); {сумма четных элементов массива С}
end.
---
текст в фигурных скобках удалять не обязательно, он на код не влияет.
0,0(0 оценок)
Ответ:
ABCD11111111
ABCD11111111
16.09.2022 10:50
Const
    N = 15;
Var A:array[1..N] of integer;
    i,Kc,Kn,Sn:integer;
Begin
Kc:=0;
Sn:=0;
Kn:=0;
Randomize;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(' ',A[i]);
    if A[i] mod 2 = 0 then Kc:=Kc+1;
    if A[i] mod 2 <> 0 then
       Begin
       Sn:=Sn+A[i];
       Kn:=Kn+1;
       End;
    if A[i]>0 then A[i]:=0;
    End;
WriteLn;
WriteLn('Количество чётных: ',Kc);
WriteLn('Среднее арифметическое нечётных: ',Sn/Kn);
Write('Новый массив:');
For i:= 1 to N do
    Write(' ',A[i])
End.

Пример:
Исходный массив: -1 4 -8 9 -6 -10 0 3 9 -1 1 4 -2 -6 3
Количество чётных: 8
Среднее арифметическое нечётных: 3.28571428571429
Новый массив: -1 0 -8 0 -6 -10 0 0 0 -1 0 0 -2 -6 0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота