В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dramidontova
dramidontova
13.05.2020 01:48 •  Информатика

Напишите программу, которая будет 5 раз генерировать два случайных числа от 1 до 10 и сохранять их в переменные x и y. После этого, программа будет спрашивать у пользователя сумму двух переменных x и y.

Если пользователь отвечает правильно, то программа начисляет ему Иначе она будет просто выводить правильный ответ.

Не забудь вывести итоговый счет, ведь всем интересно насколько хорошо они отвечали

Показать ответ
Ответ:
Света1011111
Света1011111
02.07.2021 18:38

import random

score = 0

for i in range(5):

   x = random.randint(1, 10)

   y = random.randint(1, 10)

   print("Введите сумму")

   inp = int(input())

   if x + y == inp:

       print("Верно!")

       score += 1

   else:

       print("Правильный ответ -", x + y)

print("Итоговый счёт:", score)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота