В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kolyanikolay200
kolyanikolay200
02.03.2021 21:29 •  Информатика

Напишите программу, которая будет запрашивать у пользователя число N, генерировать N случайных чисел в диапазоне от 1 до 50, для каждого
сгенерированного случайного числа вычислять сумму от 1 до этого числа и
печатать табличку чисел и сумм. Программа на питоне

Показать ответ
Ответ:
dsgsdfgasdasd
dsgsdfgasdasd
25.08.2021 18:52

Объяснение:

Python

from random import randint

def getsum(a):

   s=0

   for i in range (1,a+1):

      s+=i

   return s    

n=int(input('Введите n: '))

a=[randint(1,50) for i in range(n)]

for i in range (0, n):

  print(a[i], ' сумма =',getsum(a[i]))


Напишите программу, которая будет запрашивать у пользователя число N, генерировать N случайных чисел
0,0(0 оценок)
Ответ:
fty354y4
fty354y4
25.08.2021 18:52

Объяснение:

В конце всё ужасно некрасиво получилось, но я начинающий, так что таблицы еще знать не знаю.

Если что-то непонятно, пиши


Напишите программу, которая будет запрашивать у пользователя число N, генерировать N случайных чисел
Напишите программу, которая будет запрашивать у пользователя число N, генерировать N случайных чисел
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота