Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
ghkbkb
09.06.2022 12:59 •
Информатика
Напишите программу, которая для последовательности натуральных чисел находит среднее арифметическое. программа получает на вход числа, кол-во чисел неизвестно, последовательность заканчивается числом 0 (0 в последовательность не входит)
Показать ответ
Ответ:
arinab01p0c2kd
04.10.2020 17:09
Var
a: array[1..1000] of integer;
sa: real;
i: byte;
begin
writeln ('Введите числа: ');
i:=0;
sa:=0;
repeat
i:=i+1;
read (a[i]);
sa:=sa+a[i];
until a[i]=0;
sa:=sa/(i-1);
writeln ('Среднее арифметическое чисел = ',sa);
end.
Пример:
Введите числа:
2 4 2 4 2 4 0
Среднее арифметическое чисел = 3
0,0
(0 оценок)
Популярные вопросы: Информатика
sviridovakatya8
12.03.2021 07:56
Если цифра сотен равна 8 или 9, то число домножить на количество десятков, если число сотен от 3 до 5, то у числа оставить цифры сотен и десятков, в противном случае...
vilnur345
05.10.2022 11:52
Слова паскаль, операционная система, фортан, текстовый процессор, медицинские экспертные системы, драйвер, программы для создания презентаций, архиватор, ассемблер,...
ВсеЗнайка717
17.08.2022 17:48
X^8-x^7+x^6-x^5+x^4-x^3+x^2-x+1=0 сколько корней имеет уравнение?...
полли42
17.08.2022 17:48
Cократите дробь,предварительно разложив числитель и знаменатель дроби на множители: а) 12х-3х^3/6x+6 в) m^2-4/m^2+4m+4 г) n^2-n-1/n^4-n^3-n^2 ^2 это во второй степени...
Lelka8891
17.08.2022 17:48
Меж березюк паучок сплел красивый гамачок...
melnikovao197
17.08.2022 17:48
1кг яблок стоит 50 руб, а 1кг картофеля 70 руб. купили m кг и n кг картофеля. по какой формуле подсчитывается стоимость покупки?...
ринат127
17.08.2022 17:48
Как по будет где ты живёшь? и я живу нв заповедной улице!...
zali8
17.08.2022 17:48
Сочинение сравнение финский эпос и былины...
Loooooper
17.08.2022 17:48
Составьте сложные предложение со словами: приключение и привычка.умоляю. сижу,не могу решить : с...
oleg059
17.08.2022 17:48
Найдите в тексте существительное, образованное перехода из причастия: мафусаил признан самым старым из изучаемых в последние десятилетия живых организмов на планете,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a: array[1..1000] of integer;
sa: real;
i: byte;
begin
writeln ('Введите числа: ');
i:=0;
sa:=0;
repeat
i:=i+1;
read (a[i]);
sa:=sa+a[i];
until a[i]=0;
sa:=sa/(i-1);
writeln ('Среднее арифметическое чисел = ',sa);
end.
Пример:
Введите числа:
2 4 2 4 2 4 0
Среднее арифметическое чисел = 3