В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dymovvla01928
dymovvla01928
26.05.2021 22:18 •  Информатика

Напишите программу , которая переводит десятичные числа в эквиваленты из соответствующих систем счисления по основанию b, 10 > b < = 36.

Показать ответ
Ответ:
Anzhelika0624
Anzhelika0624
17.07.2020 06:45
Var i,k,j,n,ost,p:integer;   
x,s:string;
begin 
  read(s); 
  n:=strtoint(s); 
  for j:=11 to 36 do   
  begin     
    x:='';     
    p:=n;     
    k:=0;     
    while p<>0 do       
    begin         
      ost:=p - (p div j)*j;         
      p:=p div j;         
      k:=k+1;         
      if (ost >9) and (ost <=36) then
        x:=chr(ost+55)+x         
      else
        x:=inttostr(ost)+x;       
    end;;     
  writeln(x,'  ',j,' ss');   
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота