В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
marinka10k
marinka10k
05.03.2020 11:05 •  Информатика

Напишите программу, которая подсчитывает, сколько различных чисел содержится в данном списке. входные данные программа получает на вход несколько чисел (не более 1000), записанных в одной строке через пробел. все числа по модулю не превосходят . выходные данные программа должна вывести единственное число - количество различных чисел среди данных. пример ввод вывод 2 5 1 3 1 5 (python)

Показать ответ
Ответ:
АшадЕфремова
АшадЕфремова
08.10.2020 21:52

Например, можно действовать так: сначала отсортировать массив, а затем пройти по нему, подсчитывая количество элементов, которые не совпадают со следующим за ним элементом.

a = list(map(int, input().split()))

count = 1

a.sort()

for i in range(len(a) - 1):

    if a[i] != a[i + 1]:

        count += 1

print(count)

Но проще всего преобразовать массив в множество (set):

a = set(map(int, input().split()))

print(len(a))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота