В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ruslan3252
Ruslan3252
28.02.2021 17:52 •  Информатика

Напишите программу, которая показывает количество нечетных чисел в числе. ( если можно, то без программы while и не слишком мудро)

Показать ответ
Ответ:
abramchuk2
abramchuk2
23.07.2020 14:07
Var
  k:longint;
  d,n:integer;
begin
  Write('Введите натуральное число (1-2147483647): ');
  Read(k);
  n:=0;
  while k>0 do begin
    d:=k mod 10;
    k:=k div 10;
    if (d mod 2)<>0 then Inc(n)
  end;
  Writeln('Количество нечетных цифр в числе равно ',n)
end.

Тестовое решение:
Введите натуральное число (1-2147483647): 35632105
Количество нечетных цифр в числе равно 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота