В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Polina4645
Polina4645
30.05.2022 14:20 •  Информатика

Напишите программу, которая получает на вход три вещественных числа и находим сумму положительных из них. обьясните каждую строку.

Показать ответ
Ответ:
Швабу
Швабу
10.10.2020 04:34

Ну, наверное это должно выглядеть как то так. Я плохо помню паскаль

program Help;   #Заголовок

var  #Раздел с переменными

a, b ,c, summ : real;   #Входные переменные и по итогу их сумма, вещественные

begin  #Думаю понятно

   summ := 0;   #Инициализация summ, ибо статическая типизация

   writeln('Enter nums');   #Программа попросит ввести числа

   readln(a);  #Считывание

   readln(b);  #Считывание

   readln(c);  #Считывание

   

   if a > 0 then summ += a;  #Если переменная а больше нуля, прибавляем её к итоговой переменной

   if b > 0 then summ += b;  #Аналогично

   if c > 0 then summ += c;   #Аналогично

   

   write(summ);   #Выводим переменную summ на экран

       

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота