В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
DcPer11
DcPer11
05.02.2020 02:27 •  Информатика

Напишите программу, которая получает случайное натуральное число из отрезка [64; 511] и выводит на экран запись этого числа в восьмеричной системе счисления. Оформите вывод так, как в примере: Случайное число 83

В восьмеричной системе 123
Язык python

Показать ответ
Ответ:
наст55
наст55
18.11.2020 09:41

import random

def to8(x):

       new=''

       while x>0:

           new=str(x%8)+new

           x //= 8

       return(new)

a=random.randint(64,511)

print('Случайное число',a)

print('В восьмеричной системе',to8(a))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота