В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
saaashaaa4656
saaashaaa4656
26.09.2020 22:55 •  Информатика

Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. входные данные входная строка содержит три целых числа, разделённых пробелами. выходные данные программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные. примеры входные данные 1 2 1 выходные данные 2 питон

Показать ответ
Ответ:
12СоловьёваАнна
12СоловьёваАнна
13.07.2020 11:02

1.

а)

Переводим целую часть 365.84510 в 6-ую систему последовательным делением на 6:

365/6 = 60, остаток: 5

60/6 = 10, остаток: 0

10/6 = 1, остаток: 4

1/6 = 0, остаток: 1

36510 = 14056

Переводим дробную часть 365.84510 в 6-ую систему:

0.845·6 = 5.07

0.07·6 = 0.42

0.42·6 = 2.52

0.52·6 = 3.12

0.12·6 = 0.72

0.72·6 = 4.32

0.32·6 = 1.92

0.92·6 = 5.52

0.52·6 = 3.12

0.12·6 = 0.72

0.72·6 = 4.32

0.32·6 = 1.92

0.92·6 = 5.52

0.52·6 = 3.12

0.12·6 = 0.72

0.72·6 = 4.32

0.32·6 = 1.92

0.92·6 = 5.52

0.52·6 = 3.12

0.12·6 = 0.72

0.72·6 = 4.32

0.32·6 = 1.92

0.92·6 = 5.52

0.52·6 = 3.12

0.12·6 = 0.72

0.84510 = 0.50230415304153041530415306

б)

Переводим целую часть 101.25610 в 4-ую систему последовательным делением на 4:

101/4 = 25, остаток: 1

25/4 = 6, остаток: 1

6/4 = 1, остаток: 2

1/4 = 0, остаток: 1

10110 = 12114

Переводим дробную часть 101.25610 в 4-ую систему:

0.256·4 = 1.024

0.024·4 = 0.096

0.096·4 = 0.384

0.384·4 = 1.536

0.536·4 = 2.144

0.144·4 = 0.576

0.576·4 = 2.304

0.304·4 = 1.216

0.216·4 = 0.864

0.864·4 = 3.456

0.456·4 = 1.824

0.824·4 = 3.296

0.296·4 = 1.184

0.184·4 = 0.736

0.736·4 = 2.944

0.944·4 = 3.776

0.776·4 = 3.104

0.104·4 = 0.416

0.416·4 = 1.664

0.664·4 = 2.656

0.656·4 = 2.624

0.624·4 = 2.496

0.496·4 = 1.984

0.984·4 = 3.936

0.936·4 = 3.744

0.25610 = 0.10012021031310233012221334

2.

а) 758=6110=1111012

б)100112=1910=316

Объяснение:

0,0(0 оценок)
Ответ:
Kawaidesu43
Kawaidesu43
06.09.2021 03:23
Procedure Chisla(n : Integer);
var    a : Integer;
begin 
   if (n < 1) then 
WriteLn   
  else 
  begin 
       Read(a);       
if (Abs(a) < 1000) then       
begin           
Chisla(n-1);           
Write(a,' ');       
 end       
else           
 Chisla(n);   
 end;end; function ReadN() : Integer;
var   
n : Integer;begin   
Write('n=');   
ReadLn(n);   
if Not(n in [0..1000]) then       
n := ReadN();   
ReadN := n;end; var   
n : Integer; begin   
n := ReadN();   
WriteLn('Введите ', n, ' целых чисел через пробел и нажмите Enter'); 
   Chisla(n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота