В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Санси
Санси
12.12.2020 10:26 •  Информатика

Напишите программу которая принимает с клавиатуры целое число часов и выводит на экран! ​

Показать ответ
Ответ:
nocitronum
nocitronum
23.03.2019 11:50

type cl = class

  a: integer;

  constructor create(b: integer);

  procedure setval(b: integer);

  function getval: integer;

  procedure sq;

end;

constructor cl.create(b: integer);

begin

  a : = b;

end;

procedure cl.setval(b: integer);

begin

  a : = b;

end;

function cl.getval: integer;

begin

  getval : = a;

end;

procedure cl.sq;

begin

  if a < 0 then

    writeln('a ^ 2 = ', a * a)

  else

    writeln('error');

end;

var

  obj: cl;

  a : integer;

begin

  write('a = ');

  readln(a);

  obj : = cl.create(a);

  obj.sq;

  readln;

  obj.destroy;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота