Напишите программу, которая рассчитывает сумму за потребленную энергию по текущему показателю p2 и показателю месяца, с учетом тарифа - с руб/кват. если сумма превысит 1500 руб. вывести на экран "перерасход", если нет, то вывести "норма".
Как я понял, вам необходимо было исправить ошибки в коде. Если это так, то Program ddd; var tg, f:real; x:integer; begin readln (x); tg := sin(x)/cos(x); if x<=-3.14 then f:=ln(cos(5*x)-2*x)+1; if x>-3.14 then f:=0.35*tg*(0.1*x)-exp(ln(2*2.7)*(-0.1*x)); writeln (f); end.
Обратите внимание, что вещественные числа указываются посредством точки, а не запятой (не "0,1", а "0.1"). Функция cos должна принимать какой-либо аргумент, ибо сама по себе она не представляет никакого значения (f:=ln(cos*(5*x)-2*x)+1; -- здесь вы cos * на выражение, что неверно). Приравнивать переменные одих типов к значению других -- ошибка (f:integer; - значение типа интеджер. ln(cos(5*x)-2*x)+1; - функция ln возвращает значение типа real. Следовательно, f не может присвоить возвращаемое значение функции ln).
Ақпарат көзі – адам, ұжым және деректер. [1]. Деректерді жинау кезінде журналист ақпараттарды түрлі көздерден алады. Кейіпкер журналиске өзі немесе жолдастары жайында мәлімет беруге міндетті емес. Олардың экран алдында ашылулары үшін оған себеп, дәлел, сылтау керек. Егер олар жауап беруден бас тартқан жағдайда, қысым жасаудың қажеттігі жоқ. Мүмкін, сіз таңдаған кейіпкер туралы көпшілік пікірі басқаша болуы немесе сіз істейтін редакция жайындағы көзқарастың тым теріс бағытта да болуы мүмкін екенін ескеріңіз. Ақпарат алудың ұжымдық түріне формалды және формалды емес қатынас, жиналыс, мәжіліс, конференция, дөңгелек үстел, ба з конференциясы т.б. жатады. Мұның бағалылығы: онда шыншыл көзқарастардың үстемдік алып, журналистің проблема, оқиға туралы дәл, айқын ой түйіндеуіне жол ашатындығы. Ал айда, кей сәттерде шындықтан алып жататын деректердің де хабарланатынын ескеру керек. Журналист көпшілігінде деректерге жүгінеді. Деректермен танысуға автордың рұқсатымен кірісу қажет. Автордың рұқсаты бар екенін ескеру де қажеттілік және онда дәлдіктің кейде сәйкессіздіктің болатынын да аудиторияға қоса хабарлау шарттылық.
Program ddd;
var tg, f:real;
x:integer;
begin
readln (x);
tg := sin(x)/cos(x);
if x<=-3.14 then f:=ln(cos(5*x)-2*x)+1;
if x>-3.14 then f:=0.35*tg*(0.1*x)-exp(ln(2*2.7)*(-0.1*x));
writeln (f);
end.
Обратите внимание, что вещественные числа указываются посредством точки, а не запятой (не "0,1", а "0.1"). Функция cos должна принимать какой-либо аргумент, ибо сама по себе она не представляет никакого значения (f:=ln(cos*(5*x)-2*x)+1; -- здесь вы cos * на выражение, что неверно). Приравнивать переменные одих типов к значению других -- ошибка (f:integer; - значение типа интеджер. ln(cos(5*x)-2*x)+1; - функция ln возвращает значение типа real. Следовательно, f не может присвоить возвращаемое значение функции ln).
Ақпарат көзі – адам, ұжым және деректер. [1]. Деректерді жинау кезінде журналист ақпараттарды түрлі көздерден алады. Кейіпкер журналиске өзі немесе жолдастары жайында мәлімет беруге міндетті емес. Олардың экран алдында ашылулары үшін оған себеп, дәлел, сылтау керек. Егер олар жауап беруден бас тартқан жағдайда, қысым жасаудың қажеттігі жоқ. Мүмкін, сіз таңдаған кейіпкер туралы көпшілік пікірі басқаша болуы немесе сіз істейтін редакция жайындағы көзқарастың тым теріс бағытта да болуы мүмкін екенін ескеріңіз. Ақпарат алудың ұжымдық түріне формалды және формалды емес қатынас, жиналыс, мәжіліс, конференция, дөңгелек үстел, ба з конференциясы т.б. жатады. Мұның бағалылығы: онда шыншыл көзқарастардың үстемдік алып, журналистің проблема, оқиға туралы дәл, айқын ой түйіндеуіне жол ашатындығы. Ал айда, кей сәттерде шындықтан алып жататын деректердің де хабарланатынын ескеру керек. Журналист көпшілігінде деректерге жүгінеді. Деректермен танысуға автордың рұқсатымен кірісу қажет. Автордың рұқсаты бар екенін ескеру де қажеттілік және онда дәлдіктің кейде сәйкессіздіктің болатынын да аудиторияға қоса хабарлау шарттылық.
Объяснение: