В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tanyagag
tanyagag
01.06.2022 04:10 •  Информатика

Напишите программу, которая считает количество чётных цифр введённого числа. ---Входные данные---
Входная строка содержит одно натуральной число N .

---Выходные данные---
Программа должна вывести количество чётных цифр введённого числа.
ПРИМЕР
Ввод
123456
Вывод
3
Ввод
13579
Вывод
0
Желательно на Питоне или Паскале с использованием РЕКУРСИИ(фунции или процедуры)!

Показать ответ
Ответ:
zroslama
zroslama
07.01.2021 03:59

#include <iostream>  

using namespace std;

int main()

{

   long long a, sum = 0;

   cin >> a;

   while(a)

   {

       if((a%10) % 2)

           sum++;

       a/=10;

   }

   cout << sum << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота