В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dinaumralieva
dinaumralieva
05.05.2023 16:47 •  Информатика

Напишите программу, которая считает произведение элементов массива целых чисел. Сначала задается целое число N = размер массива (он всегда меньше или равен 10), затем N целых чисел, каждая на отдельной строке. Вывести произведение. Ввод, вывод (readln, writeln). Пример ввод

3

2

2

5

Вывод

20

Показать ответ
Ответ:
asadbekakramov
asadbekakramov
19.05.2022 22:18

Все слова/анаграммы, которые можно составить из слова "сканер"

Из "сканер" можно составить 58 слов из 2,3,4,5 букв.

Слова из 2 букв, составленные из комбинации "сканер" (12 слов):

ан ар ас ер ка кн кр на не нс ре се

Слова из 3 букв, составленные из комбинации "сканер" (22 слова):

акр аре арк аск ера кар кеа кен кер кнр нар нас нес рак рен рнк сак сан сен сер сна сне

Слова из 4 букв, составленные из комбинации "сканер" (13 слов):

акне енка каре керн крае кран крен раек река саек саке сена сера

Слова из 5 букв, составленные из комбинации "сканер" (11 слов):

аксен анкер аскер кенар нарек насек нерка серка серна скарн скена

0,0(0 оценок)
Ответ:
TToMoLLIHuK1
TToMoLLIHuK1
06.02.2020 09:21

Объяснение:

// Example program

#include <iostream>

#include <string>

int main()

{

   int k[30];

   for(int i = 0; i < 30; i ++) //заполняем случайными числами

       k[i] = rand();

   int min_sum = 999999999;

   int num1, num2;

   for(int i = 0; i < (30 - 1); i ++) //цикл поиска, i меняется от начала

                                      //до предпоследнего элемента, чтобы не выйти

                                      //за пределы при обращении к i + 1 элементу

   {

       int sum = k[i] + k[i+1];//очередная сумма

       if(sum < min_sum) //сравниваем ее с текущим минимумом

       {//если она меньше, то

           min_sum = sum;//обновляем текущую сумму

           num1 = i; num2 = i + 1;//обновляем номер

       }

   }

   //на выходе из цикла в min_sum и num1 и num2 имеем самые минимальные номера

   std::cout << "min_sum = " << min_sum << " nomer1 = " << num1 <<" nomer2 = " << num2;

}


решить задачу на C++ Дан целочисленный массив из 30 элементов. Элементы массива могут принимать прои
решить задачу на C++ Дан целочисленный массив из 30 элементов. Элементы массива могут принимать прои
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота