Напишите программу, которая считывает слово, затем выводит: «[это слово] ? Конечно, помню, ведь мы проходили это на занятии!». Пример
Ввод Вывод
print print ? Конечно, помню, ведь мы проходили это на занятии!
2)Напишите программу, которая считывает с клавиатуры одно за другим два целых числа и выводит их сумму.
Пример 1
Ввод Вывод
3 8
5
Пример 2
Ввод Вывод
34234324 86588760
52354436
1) 1000 байт; 2) 2,197 КБ
Объяснение:
1) Алфавит мощностью 32, т.е. каждый символ кодируется log2(32) = 5 битами
На экране 20 * 80 = 1600 символов
Поскольку 1 символ = 5 бит
Размер текста на экране: 1600 * 5 = 8000 бит
Поскольку 1 байт = 8 бит
8000 / 8 = 1000 байт
Результат: 1000 байт
2) Размер изображения 180 х 100 точек, следовательно 180 * 100 = 18000 точек
2 градации цвета (чёрный, белый) = 1 бит
18000 точек = 18000 бит
18000 бит в байтах = 18000 / 8 = 2250 байт
2250 байт в КБ = 2250 / 1024 = 2,197 КБ
Программа написана на языке C# (.NET Framework)
- Если число должно выдаваться пользователем:
using System;
namespace ConsoleApp2
{
class Program
{
static void Main(string[] args)
{
while (true)
{
int o = Int32.Parse(Console.ReadLine());
if (o < 100 || o > 999)
{
Console.WriteLine("Ошибка!");
Console.ReadLine();
}
else
{
int a = o / 100,
b = (o / 10) % 10,
c = o % 10;
String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);
Console.WriteLine(x);
Console.ReadLine();
}
}
}
}
}
- Если число должно выдаваться с запуском программы:
using System;
namespace ConsoleApp2
{
class Program
{
static void Main(string[] args)
{
while (true)
{
Random rnd = new Random();
int o = rnd.Next(100, 999),
a = o / 100,
b = (o / 10) % 10,
c = o % 10;
String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);
Console.WriteLine(o);
Console.WriteLine(x);
Console.ReadLine();
}
}
}
}
}