В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Anna678901
Anna678901
19.03.2020 08:56 •  Информатика

Напишите программу, которая считывает строку с числом nn, которое задаёт количество чисел, которые нужно считать. Далее считывает nn строк с числами x_ix
i

, по одному числу в каждой строке. Итого будет n+1n+1 строк.

При считывании числа x_ix
i

программа должна на отдельной строке вывести значение f(x_i)f(x
i

). Функция f(x) уже реализована и доступна для вызова.

Функция вычисляется достаточно долго и зависит только от переданного аргумента xx. Для того, чтобы уложиться в ограничение по времени, нужно избежать повторного вычисления значений.

Sample Input:

5
5
12
9
20
12
Sample Output:

11
41
47
61
41

Показать ответ
Ответ:
lenapotiy03
lenapotiy03
16.12.2020 00:58

INP = input().split(' ')

data=[]

search_for=0

for i in range(int(INP[0])-1):

   data.append([])

   data[i]=(input().split(' '))

ask = input().split(' ')

for i in range(len(ask)):

   if int(ask[i]) == 1:

      print(1)

   else:

   # Search job

       for j in range(len(data)):

           if int(data[j][1]) == int(ask[i]):

               search_for = int(data[j][0])

               break

       # Count

       k=0

       for j in range(len(data)):

           if int(data[j][0]) == search_for:

               k+=1

       print(k)

Объяснение:

0,0(0 оценок)
Ответ:
GOLUM34ruS
GOLUM34ruS
08.08.2022 01:41

ответ:Внутри условных инструкций можно использовать любые инструкции языка Питон, в том числе и условную инструкцию. Получаем вложенное ветвление – после одной развилки в ходе исполнения программы появляется другая развилка. При этом вложенные блоки имеют больший размер отступа (например, 8 пробелов). Покажем это на примере программы, которая по данным ненулевым числам x и y определяет, в какой из четвертей координатной плоскости находится точка (x,y):

x = int(input())

y = int(input())

if x > 0:

   if y > 0:               # x>0, y>0

       print("Первая четверть")

   else:                   # x>0, y<0

       print("Четвертая четверть")

else:

   if y > 0:               # x<0, y>0

       print("Вторая четверть")

   else:                   # x<0, y<0

       print("Третья четверть")

В этом примере мы использовали комментарии – текст, который интерпретатор игнорирует. Комментариями в Питоне является символ # и весь текст после этого символа до конца строки.

Объяснение:В этом примере мы использовали комментарии – текст, который интерпретатор игнорирует. Комментариями в Питоне является символ # и весь текст после этого символа до конца строки.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота