В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
артемий1456
артемий1456
14.11.2022 22:11 •  Информатика

Напишите программу, которая создаёт и выводит массив из действительных чисел случайным размером от 4 до 10 строк и столбцов, затем через пустую строку выводит тот же массив, но выводит его столбец так, чтобы поменялся местами с последним.

Показать ответ
Ответ:
Mv0856
Mv0856
09.10.2020 12:28
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var (m, n) := (Random(4, 10), Random(4, 10));

 Writeln('*** Исходный массив ***');

 var a := MatrRandomReal(m, n, -99, 99);

 a.Println(8, 3);

 Writeln('*** Полученный массив ***');

 a.SwapCols(1, a.ColCount - 1);

 a.Println(8, 3)

end.


Напишите программу, которая создаёт и выводит массив из действительных чисел случайным размером от 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота