В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу которая создаёт одномерный массив из 400 позиций заполняет его целыми случайными числами и считает количество честных и ннчётных значений. вывести результат подсчета

Показать ответ
Ответ:
Сириc
Сириc
07.05.2022 06:13

quantity = 0

amount = 0

n = int(input("Введите число: "))

while (n != 0):

   if ((n > 9 and n < 100) and (n % 7 == 0)):

       quantity += 1

       amount += n

   n = int(input())

print(quantity, amount)

arithmetic_mean = amount / quantity

print("Среднее арифметическое двузначных чисел, которые делятся на 7 = ", arithmetic_mean)

Объяснение:

quantity = 0  // Переменная, хранящая количество чисел, подходящих под условие "Двузначные числа, которые делятся на 7"

amount = 0  // Переменная, хранящая сумму чисел, подходящих под условие "Двузначные числа, которые делятся на 7"

n = int(input("Введите число: "))  // Ввод первого целочисленного значения n

while (n != 0):  // Пока переменная n ≠ 0

   if ((n > 9 and n < 100) and (n % 7 == 0)):  // Если 9 < n < 100 И остаток от деления n на 7 = 0

       quantity += 1  // Прибавляем 1 к переменной, хранящей количество чисел

       amount += n  // Прибавляем само число к переменной, хранящей сумму чисел

   n = int(input())  // Снова вводим целочисленное значение n

arithmetic_mean = amount / quantity  // Вычисление среднего арифметического

print("Среднее арифметическое двузначных чисел, которые делятся на 7 = ", arithmetic_mean) // Вывод ответа

0,0(0 оценок)
Ответ:
Snyezha
Snyezha
13.01.2020 12:52
Var     
SurName : Array [1..30] of String;       
Mark  : Array [1..30] of Real;         
Cand    : Array [1..30] of String;       
NPupil, K : Integer;                                                      

BEGIN  
Write('Сколько всего учеников ? '); 
ReadLn(NPupil); 
WriteLn('Введите фамилии и оценки учеников :'); 
For var i := 1 to NPupil do   
begin
Write(i, '. Фамилия - ');
ReadLn(SurName[i]);         
Write('     Оценка - ');    
ReadLn(Mark[i]);   
end; WriteLn; 
K:=0;  
For var i := 1 to NPupil do   
If Mark[i]=2  then     
begin
K:=K+1;
Cand[K] := SurName[i]
end; 
If K=0 then WriteLn('В КЛАССЕ НЕТ ДВОЕЧНИКОВ.')   
else 
begin
WriteLn('ДВОЕЧНИКИ :');           
For var i := 1 to K do WriteLn( i, '. ' , Cand[i]);     
end;
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота