В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Анют2006
Анют2006
13.01.2022 21:47 •  Информатика

Напишите программу, которая удаляет из строки все повторяющиеся символы. входные данные на вход программы подаётся строка, содержащая символы таблицы ascii. выходные данные программа должна вывести исходную строку, из которой удалены все повторяющиеся символы. примеры входные данные abc13a1b2z3c выходные данные abc132z входные данные qwasd123 выходные данные qwasd123 pascal abc 1.8

Показать ответ
Ответ:
Лера15012003
Лера15012003
05.10.2020 13:39

var str:string;i,n:integer;

begin

readln(str);

for i := 1 to length(str)-1 do

for n:=length(str) downto i+1 do

if str[n]=str[i]then delete(str,n,1);

writeln(str);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота