В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Hahaha1234567890
Hahaha1234567890
15.11.2020 04:01 •  Информатика

Напишите программу, которая в последовательности целых чисел находит сумму четных чисел в диапазоне от 5 до 25. программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введенные числа по модулю не превышают 30000. программа должна вывести одно число: сумму четных чисел в диапазоне от 5 до 25. входные данные : 4, 16, 17, 26,0 выходные данные: 16

Показать ответ
Ответ:
Elizabeth041100
Elizabeth041100
14.06.2020 23:36

Program Summa;

Uses Crt;

var s,n,c:integer;

 

 begin

   clrscr;

   write('Введите числа коннц ввода 0: ');

    s:=0;c:=0; 

    repeat

        readln(n);

        c:=c+1; 

if (n mod 2)=0 then
      if ((n>=5)and (n<=25)) then s:=s+n;        

  until (n=0) or (c=1000) ;    

write('Сумма ',c,' чётных чисел в диапазоне от 5 до 25:',s);

   readkey;

 

end. 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота