Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256. использовать масив a: array
Система счисления - метод записи чисел с определённого набора специальных символов (цифр) и сопоставления этим записям возможных значений.
Системы счисления бывают: позиционные (пример, десятичная и двоичная СС), непозиционные (пример, арабская или римская СС), смешанные (пример, счёт минут, часов).
Основанием системы счисления - набор символов (цифр), используемых в каждом из разрядов данного числа для его изображения в данной системе счисления
ИЛИ
Основание системы счисления - количество цифр и символов, использующихся для записи и демонстрации числа.
const n=100;
var ar:array of array of integer;
ars:array of array of string;
i:integer;
procedure complection(var ar:array of array of integer;var ars:array of array of string);
var
i,j:integer;
begin;
for i:=1 to n do
begin;
for j:=1 to n do
begin;
ar[i,j]:=random(9);
str(ar[i,j],ars[i,j]);
end;
end;
end;
procedure burning(ars:array of array of string);
var
i,j:integer;
t:text;
begin;
assign(t,'text.txt');
rewrite(t);
for i:=1 to n do
begin;
writeln(t,' ');
for j:=1 to n do
write(t,ars[i,j],' ');
end;
end;
begin;
randomize;
setlength(ar,n+1);
setlength(ars,n+1);
for i:=1 to n do
begin;
setlength(ar[i],n+1);
setlength(ars[i],n+1);
end;
complection(ar,ars);
burning(ars);
end.