В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Caxapok24
Caxapok24
26.06.2021 12:26 •  Информатика

Напишите программу, которая в последовательности целых чисел определяет среднее арифметическое отрицательных чисел, кратных 6. программа получает на вход целые числа, среди них есть хотя бы одно отрицательное число, кратное 6, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести одно число: среднее арифметическое отрицательных чисел, кратных 6. напишите программу, которая в последовательности натуральных чисел определяет сумму чётных чисел, кратных 3. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: сумму чётных чисел, кратных 3

Показать ответ
Ответ:
misskamii
misskamii
09.10.2020 23:55
Program n1;
var a,sum,k: integer;
begin
readln(a);
sum:=0;
k:=0;
while a<>0 do begin
if (a<0) and (a mod 6=0) then begin
k:=k+1;
sum:=sum+a;
end;
readln(a);
end;
writeln(sum/k);
end.

Program n2;
var a,sum: integer;
begin
readln(a);
sum:=0;
while a<>0 do begin
if (a mod 2=0) and (a mod 3=0) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота