В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Сэээээ
Сэээээ
02.03.2023 17:05 •  Информатика

Напишите программу, которая в последовательности натуральных чисел находит
минимальное нечетное трехзначное число или сообщает, что таких чисел нет. На вход
программы подаются количество чисел n, а дальше сами числа x. Программа должна
вывести минимальное четное трехзначное число или вывести NO, если таких чисел в
последовательности нет. PASCAL ОЧЕНЬ

Показать ответ
Ответ:
48096остьлмс
48096остьлмс
15.10.2020 11:04

var i, min, x, n:Integer;

begin

min:=1000;

 readln(n);

 for i := 1 to n do

 begin

   readln(x);

   if (x < min) and (x mod 2 <> 0) and (x>=100) and (x<1000) then  

   min:=x;

  end;

  if min = 1000 then  

writeln('NO')

else

writeln(min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота