Напишите программу, которая вводит адрес файла и «разбирает» его на части, разделенные знаком '/'. каждую часть нужно вывести в отдельной строке. пример: введите адрес файла: c: /фото/2015/байкал/shaman.jpg c: фото 2015 байкал shaman.jpg на языке паскаль и с объяснениями !
```pascal
procedure ParseAddress;
var
address, part : string;
begin
// Вводим адрес файла
writeln('Введите адрес файла: ');
readln(address);
// Инициализируем разделитель '/'
part := '';
// Проходим по каждому символу в адресе файла
for i := 1 to length(address) do
begin
// Если символ является разделителем '/', выводим текущую часть адреса
if address[i] = '/' then
begin
writeln(part);
part := '';
end
else
// Иначе добавляем символ к текущей части адреса
part := part + address[i];
end;
// Выводим последнюю часть адреса файла
writeln(part);
end;
begin
ParseAddress; // Вызываем процедуру для разбора адреса файла
end.
```
Давайте теперь разберемся, как работает программа:
1. Сначала мы объявляем переменные `address` (для хранения адреса файла), `part` (для хранения текущей части адреса файла) и `i` (для итерации по символам в адресе файла).
2. Мы выводим сообщение пользователю, чтобы ввести адрес файла.
3. С помощью цикла `for` мы проходим по каждому символу в адресе файла.
4. Мы проверяем, является ли текущий символ разделителем '/'. Если это так, то это означает, что мы достигли конца текущей части адреса. Поэтому мы выводим текущую часть, используя `writeln`, и затем сбрасываем `part`.
5. Если текущий символ не является разделителем '/', это означает, что он принадлежит текущей части адреса. Поэтому мы добавляем символ к текущей части `part`.
6. Наконец, мы выводим последнюю часть адреса файла, чтобы ничего не пропустить.
Таким образом, программа разбирает адрес файла на части, разделенные символом '/'. Каждая часть выводится в отдельной строке с использованием `writeln`.
Этот код даст вам возможность понять и реализовать эту программу на языке Паскаль.