В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kolyuchka
kolyuchka
12.09.2021 03:55 •  Информатика

Напишите программу которая вводит четырехзначное число и определяет верно ли что его десятичной записи цифры стоят в порядке возрастания

Показать ответ
Ответ:
Artem152006
Artem152006
29.05.2020 09:18

пишем имя программы

Program:chetre;

вводим переменные. для ввода переменных в программе используется тег <var> , который нужен для выделения переменных компьютерных программ

Var

n,i:

после ввода переменных ставим двоеточие и вводим тип данных ,в данном случае это целое или на языке паскаль integer

Var

n,i: integer;

теперь пишем начало

Begin

введём переменную n

Write('n = ');Read(n);

теперь присваиваем  значение переменной i

i:=0;

дальше вы наверное всё поймёте

if n div 1000 = n mod 10 then i:=i+1;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if i=1 then Write('Верно')

else Write('Не верно')

End.

вот полная программа без всяких вставок

Рrogram:chetre;

Var

n,i:integer;

Begin

Write('n = ');Read(n);

i:=0;

if n div 1000 = n mod 10 then i:=i+1;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if i=1 then Write('Верно')

else Write('Не верно')

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота