В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ladyalinaELIZ
ladyalinaELIZ
01.01.2020 01:28 •  Информатика

Напишите программу которая вводит натуральные числа a и n и вычисляет a^n без использования операции возведения в степень.

Показать ответ
Ответ:
Тёмаэх
Тёмаэх
04.10.2020 12:41
Var a, n, i: integer;
  r: longint;
 begin
  r := 1;
  readln(a, n);
  for i := 1 to n do
  r := r * a;
  write(r);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота